Return a transform representing the relative position of the coupler at index couplerPositionIndex in the set.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- couplerPositionIndex
- Type: SystemInt32
An index between 0 and (CouplerQuantity-1).
Return Value
Returns a transformation that is composed from : - a translation from (0, 0, 0) to coupler origin - a rotation that will align the coupler with the bar segment on which it stays.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | couplerPositionIndex is not in the range [ 0, CouplerQuantity-1 ]. |