Rebar |
Return a transform representing the relative position of the coupler at index couplerPositionIndex in the set.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- couplerPositionIndex Int32
- An index between 0 and (CouplerQuantity-1).
Return Value
TransformReturns a transformation that is composed from : - a translation from (0, 0, 0) to coupler origin - a rotation that will align the coupler with the bar segment on which it stays.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | couplerPositionIndex is not in the range [ 0, CouplerQuantity-1 ]. |