AddCurve Method


Add a curve to the shape representation stored in this WireframeBuilder.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public void AddCurve(
	Curve GCurve
)
Visual Basic
Public Sub AddCurve ( _
	GCurve As Curve _
)
Visual C++
public:
void AddCurve(
	Curve^ GCurve
)

Parameters

GCurve
Type: Autodesk.Revit.DBCurve
The curve to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException GCurve is not acceptable for a wireframe shape representation.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also