Exports a selection of views in DGN format.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- folder
- Type: SystemString
Output folder, into which file(s) will be exported. The folder must exist.
- name
- Type: SystemString
Either the name of a single file or a prefix for a set of files. If empty, automatic naming will be used. If a null reference (Nothing in Visual Basic), throw ArgumentException.
- views
- Type: System.Collections.GenericICollectionElementId
Selection of views to be exported. The set must contain at least one valid view.
- options
- Type: Autodesk.Revit.DBDGNExportOptions
Various options applicable to the DGN format. If a null reference (Nothing in Visual Basic), all options will be set to their respective default values.
Return Value
True if successful, otherwise False.Remarks
All the views must be printable for the Export to succeed. It can be assured by checking the CanBePrinted property of each view.
Examples

public bool ExportDGN(Document document, View view)
{
bool exported = false;
// Get predefined setups and use the first one
IList<string> setupNames = BaseExportOptions.GetPredefinedSetupNames(document);
if (setupNames.Count > 0)
{
// Get predefined options for first predefined setup
DGNExportOptions dgnOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames[0]);
// export the active view if it is printable
if (view.CanBePrinted == true)
{
ICollection<ElementId> views = new List<ElementId>();
views.Add(view.Id);
exported = document.Export(Path.GetDirectoryName(document.PathName),
Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions);
}
}
return exported;
}

Public Function ExportDGN(document As Document, view As View) As Boolean
Dim exported As Boolean = False
' Get predefined setups and use the first one
Dim setupNames As IList(Of String) = BaseExportOptions.GetPredefinedSetupNames(document)
If setupNames.Count > 0 Then
' Get predefined options for first predefined setup
Dim dgnOptions As DGNExportOptions = DGNExportOptions.GetPredefinedOptions(document, setupNames(0))
' export the active view if it is printable
If view.CanBePrinted = True Then
Dim views As ICollection(Of ElementId) = New List(Of ElementId)()
views.Add(view.Id)
exported = document.Export(Path.GetDirectoryName(document.PathName), Path.GetFileNameWithoutExtension(document.PathName), views, dgnOptions)
End If
End If
Return exported
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | NullOrEmpty -or- Contains invalid characters. -or- non empty list of views must be provided. -or- some of the views are not printable (exportable). -or- Thrown when the options in DGNExportOptions is invalid. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsDirectoryNotFoundException | Thrown when the directory does not exist. |
Autodesk.Revit.ExceptionsInvalidOperationException | Export is temporarily disabled. -or- Exporting is not allowed in the current application mode. |
Autodesk.Revit.ExceptionsInvalidPathArgumentException | The folder does not exist. |
Autodesk.Revit.ExceptionsOptionalFunctionalityNotAvailableException | The DWG module is not available in the installed Revit. -or- The Graphics module is not available in the installed Revit. |