IsNameUnique Method


Validates whether the material name is unique in document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public static bool IsNameUnique(
	Document aDocument,
	string name
)
Visual Basic
Public Shared Function IsNameUnique ( _
	aDocument As Document, _
	name As String _
) As Boolean
Visual C++
public:
static bool IsNameUnique(
	Document^ aDocument, 
	String^ name
)

Parameters

aDocument
Type: Autodesk.Revit.DBDocument
The document in which the name is being tested for uniqueness.
name
Type: SystemString
The name tested for uniqueness.

Return Value

Returns true if the name is unique, and false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also