IsNameUnique Method


Material Is Name Unique Method

Validates whether the material name is unique in document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool IsNameUnique(
	Document aDocument,
	string name
)

Parameters

aDocument Document
The document in which the name is being tested for uniqueness.
name String
The name tested for uniqueness.

Return Value

Boolean
Returns true if the name is unique, and false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also