IsValidExternalGeometryId Method


Validates that the input ExternalGeometryId can be assigned to a direct shape reference.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public static bool IsValidExternalGeometryId(
	ExternalGeometryId externalId
)
Visual Basic
Public Shared Function IsValidExternalGeometryId ( _
	externalId As ExternalGeometryId _
) As Boolean
Visual C++
public:
static bool IsValidExternalGeometryId(
	ExternalGeometryId^ externalId
)

Parameters

externalId
Type: Autodesk.Revit.DBExternalGeometryId
The ExternalGeometryId to assign to the reference.

Return Value

True if the provided ExternalGeometryId is valid, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also