The ID of the grouped schedule field used to calculate percentage totals.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
InvalidElementId or the ID of the grouped field.Remarks
A Percentage field calculates what percent of the total of another field each element represents. If PercentageBy is InvalidScheduleFieldId, the total is of all elements in the schedule. If PercentageBy is the ID of one of the fields that the schedule is grouped by, the total is of all elements in that group.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | When setting this property: percentageBy is not InvalidScheduleFieldId or the ID of a field that the schedule is grouped by. |
Autodesk.Revit.ExceptionsArgumentNullException | When setting this property: A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | When setting this property: This ScheduleField is not a percentage field. |