Schedule |
The ID of the grouped schedule field used to calculate percentage totals.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)


Exception | Condition |
---|---|
ArgumentException | When setting this property: percentageBy is not InvalidScheduleFieldId or the ID of a field that the schedule is grouped by. |
ArgumentNullException | When setting this property: A non-optional argument was null |
InvalidOperationException | When setting this property: This ScheduleField is not a percentage field. |

A Percentage field calculates what percent of the total of another field each element represents. If PercentageBy is InvalidScheduleFieldId, the total is of all elements in the schedule. If PercentageBy is the ID of one of the fields that the schedule is grouped by, the total is of all elements in that group.