CreateReflection Method


Creates a transform that represents a reflection across the given plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static Transform CreateReflection(
	Plane plane
)
Visual Basic
Public Shared Function CreateReflection ( _
	plane As Plane _
) As Transform
Visual C++
public:
static Transform^ CreateReflection(
	Plane^ plane
)

Parameters

plane
Type: Autodesk.Revit.DBPlane
The plane.

Return Value

The new transform.

Examples

CopyC#
private Transform Reflect(ReferencePlane refPlane)
{
    Transform mirTrans = Transform.CreateReflection(refPlane.GetPlane());

    return mirTrans;
}
CopyVB.NET
Private Function Reflect(refPlane As ReferencePlane) As Transform
    Dim mirTrans As Transform = Transform.CreateReflection(refPlane.GetPlane())

    Return mirTrans
End Function

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was NULL

See Also