IsValidFamilyForNoteBlock Method


Checks whether a family can be used for a note block.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static bool IsValidFamilyForNoteBlock(
	Document document,
	ElementId familyId
)
Visual Basic
Public Shared Function IsValidFamilyForNoteBlock ( _
	document As Document, _
	familyId As ElementId _
) As Boolean
Visual C++
public:
static bool IsValidFamilyForNoteBlock(
	Document^ document, 
	ElementId^ familyId
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
familyId
Type: Autodesk.Revit.DBElementId
The family ID to check.

Return Value

True if the family can be used for a note block, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also