DefaultConstructionTypeId Property


The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public ElementId DefaultConstructionTypeId { get; set; }
Visual Basic
Public Property DefaultConstructionTypeId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ DefaultConstructionTypeId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The input element is not a constructionType.
Autodesk.Revit.ExceptionsArgumentNullException When setting this property: A non-optional argument was null

See Also