DefaultConstructionTypeId Property


Conceptual Surface Type Default Construction Type Id Property

The element id of the user specified ConceptualConstructionType to be used by default on creation for mass faces of this mass subcategory.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ElementId DefaultConstructionTypeId { get; set; }

Property Value

ElementId
Exceptions
Exception Condition
ArgumentException When setting this property: The input element is not a constructionType.
ArgumentNullException When setting this property: A non-optional argument was null
See Also