GetThemeName Method


Gets the theme name for the given theme type.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static string GetThemeName(
	UITheme frameTheme
)
Visual Basic
Public Shared Function GetThemeName ( _
	frameTheme As UITheme _
) As String
Visual C++
public:
static String^ GetThemeName(
	UITheme frameTheme
)

Parameters

frameTheme
Type: Autodesk.Revit.UIUITheme
The theme.

Return Value

The name of the theme.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also