Scale Method


Scales the bounding box by given scale.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public void Scale(
	double scale
)
Visual Basic
Public Sub Scale ( _
	scale As Double _
)
Visual C++
public:
void Scale(
	double scale
)

Parameters

scale
Type: SystemDouble
The scale value. It should be greater than zero.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The scale is invalid.

See Also