Checks whether the specified element can be used as a host for the railing. The host can be:
- stairs
- stairs component
- ramp
- floor
- slab edge
- wall
- roof
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hostId
- Type: Autodesk.Revit.DBElementId
Element id to check.
Return Value
True if the element can be used as host for the railing.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |