RailingCanBeHostedByElement Method


Railing Railing Can Be Hosted By Element Method

Checks whether the specified element can be used as a host for the railing. The host can be:
  • stairs
  • stairs component
  • ramp
  • floor
  • slab edge
  • wall
  • roof

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public bool RailingCanBeHostedByElement(
	ElementId hostId
)

Parameters

hostId ElementId
Element id to check.

Return Value

Boolean
True if the element can be used as host for the railing.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also