Create Method


Creates a new DataStorage element and adds it to the document.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public static DataStorage Create(
	Document doc
)
Visual Basic
Public Shared Function Create ( _
	doc As Document _
) As DataStorage
Visual C++
public:
static DataStorage^ Create(
	Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
Document to which the new element should be added.

Return Value

The newly created DataStorage element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also