The exception that is thrown when referencing an object that is no longer valid.
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
The object may no longer exist for many reasons:
- The object was explicitly deleted from the database.
- A change to other database items caused the item to be automatically deleted from the database.
- The object no longer exists as its creation was undone (by rolling a transaction back).
Inheritance Hierarchy
SystemObject
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsInvalidOperationException
Autodesk.Revit.ExceptionsInvalidObjectException
SystemException
Autodesk.Revit.ExceptionsApplicationException
Autodesk.Revit.ExceptionsInvalidOperationException
Autodesk.Revit.ExceptionsInvalidObjectException