Invalid |
The exception that is thrown when referencing an object that is no longer valid.

System Object
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions InvalidOperationException
Autodesk.Revit.Exceptions InvalidObjectException
System Exception
Autodesk.Revit.Exceptions ApplicationException
Autodesk.Revit.Exceptions InvalidOperationException
Autodesk.Revit.Exceptions InvalidObjectException
Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

The InvalidObjectException type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetObjectData | Retrieves data needed to serialize the target object. (Overrides InvalidOperationException GetObjectData(SerializationInfo, StreamingContext) ) |

The object may no longer exist for many reasons:
- The object was explicitly deleted from the database.
- A change to other database items caused the item to be automatically deleted from the database.
- The object no longer exists as its creation was undone (by rolling a transaction back).