Rehost Method (SketchPlane, XYZ)


Rehost Form to sketch plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void Rehost(
	SketchPlane sketchPlane,
	XYZ location
)
Visual Basic
Public Sub Rehost ( _
	sketchPlane As SketchPlane, _
	location As XYZ _
)
Visual C++
public:
void Rehost(
	SketchPlane^ sketchPlane, 
	XYZ^ location
)

Parameters

sketchPlane
Type: Autodesk.Revit.DBSketchPlane
The sketch plane on which to rehost the form.
location
Type: Autodesk.Revit.DBXYZ
The location to which to Rehost the form.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when the sketchPlane or location is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationExceptionThrown when rehosting Form failed.

See Also