Rehost Method (SketchPlane, XYZ)


Form Rehost(Sketch Plane, XYZ) Method

Rehost Form to sketch plane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void Rehost(
	SketchPlane sketchPlane,
	XYZ location
)

Parameters

sketchPlane SketchPlane
The sketch plane on which to rehost the form.
location XYZ
The location to which to Rehost the form.
Exceptions
Exception Condition
ArgumentNullException Thrown when the sketchPlane or location is .
InvalidOperationException Thrown when rehosting Form failed.
See Also