Export Method


The method that Revit will invoke to perform an export to Navisworks.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
void Export(
	Document document,
	string folder,
	string name,
	NavisworksExportOptions options
)
Visual Basic
Sub Export ( _
	document As Document, _
	folder As String, _
	name As String, _
	options As NavisworksExportOptions _
)
Visual C++
void Export(
	Document^ document, 
	String^ folder, 
	String^ name, 
	NavisworksExportOptions^ options
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document to export.
folder
Type: SystemString
The folder path.
name
Type: SystemString
The file name.
options
Type: Autodesk.Revit.DBNavisworksExportOptions
The export options.

See Also