Sets the value of the apparent current parameter for a spare
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- row
- Type: SystemInt32
A row where the valid spare is
- column
- Type: SystemInt32
A column where the valid spare is
- idCurrentParameter
- Type: Autodesk.Revit.DBElementId
One of 4 valid current parameters: RBS_ELEC_APPARENT_CURRENT_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEA_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEB_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEC_PARAM
- value
- Type: SystemDouble
The value of the spare's current for the given parameter
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The current parameter id is not valid. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The given value for value must be non-negative. |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | The row column combination does not represent a valid spare. |