Panel |
Sets the value of the apparent current parameter for a spare
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetSpareCurrentValue(
int row,
int column,
ElementId idCurrentParameter,
double value
)
Parameters
- row Int32
- A row where the valid spare is
- column Int32
- A column where the valid spare is
- idCurrentParameter ElementId
- One of 4 valid current parameters: RBS_ELEC_APPARENT_CURRENT_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEA_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEB_PARAM, RBS_ELEC_APPARENT_CURRENT_PHASEC_PARAM
- value Double
- The value of the spare's current for the given parameter

Exception | Condition |
---|---|
ArgumentException | The current parameter id is not valid. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The given value for value must be non-negative. |
ArgumentsInconsistentException | The row column combination does not represent a valid spare. |