Returns a list of names of predefined setups of export options.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
A Revit document to retrieve names from.
Return Value
An array of strings representing names of predefined setups.Remarks
The predefined setups may be used for export to both DWG and DXF formats. To get predefined options in the desired format use the static method getPredefinedOptions defined in DWGExportOptions or DXFExportOptions respectively.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | document is not a project document. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |