GetPredefinedSetupNames Method


Base Export Options Get Predefined Setup Names Method

Returns a list of names of predefined setups of export options.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static IList<string> GetPredefinedSetupNames(
	Document document
)

Parameters

document Document
A Revit document to retrieve names from.

Return Value

IList String
An array of strings representing names of predefined setups.
Exceptions
Exception Condition
ArgumentException document is not a project document.
ArgumentNullException A non-optional argument was null
Remarks
The predefined setups may be used for export to both DWG and DXF formats. To get predefined options in the desired format use the static method getPredefinedOptions defined in DWGExportOptions or DXFExportOptions respectively.
See Also