AddAnnotation Method


Adds an annotation handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void AddAnnotation(
	IFCAnyHandle annoHnd,
	IFCLevelInfo levelInfo,
	bool relateToLevel
)
Visual Basic
Public Sub AddAnnotation ( _
	annoHnd As IFCAnyHandle, _
	levelInfo As IFCLevelInfo, _
	relateToLevel As Boolean _
)
Visual C++
public:
void AddAnnotation(
	IFCAnyHandle^ annoHnd, 
	IFCLevelInfo^ levelInfo, 
	bool relateToLevel
)

Parameters

annoHnd
Type: Autodesk.Revit.DB.IFCIFCAnyHandle
The annotation handle.
levelInfo
Type: Autodesk.Revit.DB.IFCIFCLevelInfo
Information on the associated level. Optional, can be a null reference (Nothing in Visual Basic).
relateToLevel
Type: SystemBoolean
True to relate the annotation to the level, false otherwise.

Remarks

If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also