AddAnnotation Method


IFCProduct Wrapper Add Annotation Method

Adds an annotation handle to associate with the IfcProduct in this wrapper.

Namespace: Autodesk.Revit.DB.IFC
Assembly: RevitAPIIFC (in RevitAPIIFC.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddAnnotation(
	IFCAnyHandle annoHnd,
	IFCLevelInfo levelInfo,
	bool relateToLevel
)

Parameters

annoHnd IFCAnyHandle
The annotation handle.
levelInfo IFCLevelInfo
Information on the associated level. Optional, can be .
relateToLevel Boolean
True to relate the annotation to the level, false otherwise.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
If the IFCLevelInfo is not provided, and relateToLevel to true, the handle will be associated to the building handle.
See Also