RemoveInstanceVoidCut Method


Remove a cut applied to the element by a cutting instance with unattached voids.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static void RemoveInstanceVoidCut(
	Document document,
	Element element,
	Element cuttingInstance
)
Visual Basic
Public Shared Sub RemoveInstanceVoidCut ( _
	document As Document, _
	element As Element, _
	cuttingInstance As Element _
)
Visual C++
public:
static void RemoveInstanceVoidCut(
	Document^ document, 
	Element^ element, 
	Element^ cuttingInstance
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document containing the two elements
element
Type: Autodesk.Revit.DBElement
The element being cut
cuttingInstance
Type: Autodesk.Revit.DBElement
The cutting family instance

Examples

CopyC#
// remove all cuts in all family instances created by void-cutting instances
void RemoveVoidCuts(Autodesk.Revit.DB.Document doc, FamilySymbol cuttingSymbol)
{
    FilteredElementCollector collector = new FilteredElementCollector(doc);
    collector.WherePasses(new FamilyInstanceFilter(doc, cuttingSymbol.Id)); // find elements that are family instances of the cutting family

    foreach (FamilyInstance instance in collector)
    {
        foreach (ElementId elementId in InstanceVoidCutUtils.GetElementsBeingCut(instance)) // elements being cut by this instance of the cutting family
        {
            InstanceVoidCutUtils.RemoveInstanceVoidCut(doc, doc.GetElement(elementId), instance); // remove the cut
        }
    }
}
CopyVB.NET
' remove all cuts in all family instances created by void-cutting instances
Private Sub RemoveVoidCuts(doc As Autodesk.Revit.DB.Document, cuttingSymbol As FamilySymbol)
    Dim collector As New FilteredElementCollector(doc)
    collector.WherePasses(New FamilyInstanceFilter(doc, cuttingSymbol.Id))
    ' find elements that are family instances of the cutting family
    For Each instance As FamilyInstance In collector
        For Each elementId As ElementId In InstanceVoidCutUtils.GetElementsBeingCut(instance)
            ' elements being cut by this instance of the cutting family
                ' remove the cut
            InstanceVoidCutUtils.RemoveInstanceVoidCut(doc, doc.GetElement(elementId), instance)
        Next
    Next
End Sub

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException No instance void cut exists between the two elements.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Failed to remove the instance cut from the element

See Also