Identifies if a reference may be used as the parent of a face wall.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- faceReference
- Type: Autodesk.Revit.DBReference
The reference.
Return Value
True if the reference is valid as a parent to a face wall, false otherwise.Remarks
The reference must represent a face of a massing instance, and must be planar, and its normal must not be vertical or horizontal.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |