Face |
Identifies if a reference may be used as the parent of a face wall.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public static bool IsValidFaceReferenceForFaceWall(
Document document,
Reference faceReference
)
Parameters
Return Value
BooleanTrue if the reference is valid as a parent to a face wall, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

The reference must represent a face of a massing instance, and must be planar, and its normal must not be vertical or horizontal.