Informs the filter that a series of points within a given cell is about to be checked.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- min
- Type: Autodesk.Revit.DBXYZ
The lower corner of the cell.
- max
- Type: Autodesk.Revit.DBXYZ
The upper corner of the cell.
- numTests
- Type: SystemInt32
The engine's estimate of the number of TestPoint() calls it is going to make for this cell.
Remarks
This is a performance hook that the filter can use to minimize computational work per TestPoint() call within a given cell. The engine should guarantee that all points passed to TestPoint() calls will fall inside the (min, max) box specified here. This promise must be in effect until the next PrepareForCell() call.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |