PrepareForCell Method


Point Cloud Filter Prepare For Cell Method

Informs the filter that a series of points within a given cell is about to be checked.

Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void PrepareForCell(
	XYZ min,
	XYZ max,
	int numTests
)

Parameters

min XYZ
The lower corner of the cell.
max XYZ
The upper corner of the cell.
numTests Int32
The engine's estimate of the number of TestPoint() calls it is going to make for this cell.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
Remarks
This is a performance hook that the filter can use to minimize computational work per TestPoint() call within a given cell. The engine should guarantee that all points passed to TestPoint() calls will fall inside the (min, max) box specified here. This promise must be in effect until the next PrepareForCell() call.
See Also