IsParameterModifiable Method


Checks if given parameter of this subelement is modifiable.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018

Syntax

C#
public bool IsParameterModifiable(
	ElementId parameterId
)
Visual Basic
Public Function IsParameterModifiable ( _
	parameterId As ElementId _
) As Boolean
Visual C++
public:
bool IsParameterModifiable(
	ElementId^ parameterId
)

Parameters

parameterId
Type: Autodesk.Revit.DBElementId
Parameter id.

Return Value

True if given parameter of this subelement is modifiable, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also