IsValidNonContinuousRailProfile Method


Checks whether the input id represents a profile which can be used as the profile of this non-continuous rail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2019

Syntax

C#
public bool IsValidNonContinuousRailProfile(
	ElementId profileId
)
Visual Basic
Public Function IsValidNonContinuousRailProfile ( _
	profileId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidNonContinuousRailProfile(
	ElementId^ profileId
)

Parameters

profileId
Type: Autodesk.Revit.DBElementId
The profile Id to be checked.

Return Value

True if the ElementId refers to a valid NonContinuousRail profile, false otherwise.

Remarks

InvalidElementId is considered a valid NonContinuousRail profile (the default profile).

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also