Non |
Checks whether the input id represents a profile which can be used as the profile of this non-continuous rail.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- profileId ElementId
- The profile Id to be checked.
Return Value
BooleanTrue if the ElementId refers to a valid NonContinuousRail profile, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

InvalidElementId is considered a valid NonContinuousRail profile (the default profile).