FindGenericConnectionType Method


Finds StructuralConnectionHandlerType which is Generic Connection type.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 22.0.0.0 (22.1.0.0)
Since: 2017

Syntax

C#
public static ElementId FindGenericConnectionType(
	Document doc
)
Visual Basic
Public Shared Function FindGenericConnectionType ( _
	doc As Document _
) As ElementId
Visual C++
public:
static ElementId^ FindGenericConnectionType(
	Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB Document

Return Value

Returns id of StructuralConnectionHandlerType which is Generic Connection type of invalidElementId if not found.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was null

See Also