Constructs a new instance of a file to match elements that have a given phase statuses on the input phase, with the option to match all elements that have a phase status other than the input statuses.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- phaseId
- Type: Autodesk.Revit.DBElementId
Id of the phase.
- phaseStatuses
- Type: System.Collections.GenericICollectionElementOnPhaseStatus
Target statuses.
- inverted
- Type: SystemBoolean
True to match all phase statuses other than the input statuses.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |