GetStartingViewSettings Method


Returns the starting view settings for the specified document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static StartingViewSettings GetStartingViewSettings(
	Document doc
)
Visual Basic
Public Shared Function GetStartingViewSettings ( _
	doc As Document _
) As StartingViewSettings
Visual C++
public:
static StartingViewSettings^ GetStartingViewSettings(
	Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DBDocument
The document to get the settings from, which must be a project document.

Return Value

The starting view settings for the document.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException doc is not a project document.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also