SingleServerService Class


This class represents a single-server service inside Revit application. It is created when an instance of ISingleServerService is registered with Revit.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public class SingleServerService : ExternalService
Visual Basic
Public Class SingleServerService _
	Inherits ExternalService
Visual C++
public ref class SingleServerService : public ExternalService

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DB.ExternalServiceExternalService
    Autodesk.Revit.DB.ExternalServiceSingleServerService

See Also