SingleServerService Class


Single Server Service Class

This class represents a single-server service inside Revit application. It is created when an instance of ISingleServerService is registered with Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.ExternalService ExternalService
Autodesk.Revit.DB.ExternalService SingleServerService

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SingleServerService : ExternalService

The SingleServerService type exposes the following members.

Properties
Name Description
Public property Description The description for the service
(Inherited from ExternalService )
Public property IsSerializable Indicates whether executions of the service requires serialization in documents or not.
(Inherited from ExternalService )
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from ExternalService )
Public property Name The name of the service
(Inherited from ExternalService )
Public property NumberOfServers Indicates the number of servers currently registered with the service.
(Inherited from ExternalService )
Public property ServiceId The Id of the service
(Inherited from ExternalService )
Public property SupportActivation Indicates if the service supports activation/deactivation of the servers.
(Inherited from ExternalService )
Public property VendorId The vendor who provided the service
(Inherited from ExternalService )
Top
Methods
Name Description
Public method AddServer Registers a server with its service.
(Inherited from ExternalService )
Public method Dispose
(Inherited from ExternalService )
Public method Equals Determines whether the specified object is equal to the current object.
(Inherited from Object )
Public method GetActiveServerId Returns the Id of the currently active application-level server of the service.
Public method GetActiveServerId(Document) Returns the Id of the server currently associated with the given document for the service.
Public method GetDefaultServerId Returns the Id of the default server if one was assigned to the service.
(Inherited from ExternalService )
Public method GetHashCode Serves as the default hash function.
(Inherited from Object )
Public method GetOptions A copy of the options the service was registered with.
(Inherited from ExternalService )
Public method GetPublicAccessKey Access key to use to execute a service.
(Inherited from ExternalService )
Public method GetRegisteredServerIds Returns Ids of all servers registered for the service.
(Inherited from ExternalService )
Public method GetServer Returns the instance that provides implementation for a registered server.
(Inherited from ExternalService )
Public method GetType Gets the Type of the current instance.
(Inherited from Object )
Public method IsRegisteredServerId Checks if the Id represents a valid server that has been registered for the service.
(Inherited from ExternalService )
Public method RemoveServer Removes/unregisters a server from the service.
(Inherited from ExternalService )
Public method SetActiveServer(Guid) Set an active server applicable application-wide for the service.
Public method SetActiveServer(Guid, Document) Change the active server for a specific document.
Public method ToString Returns a string that represents the current object.
(Inherited from Object )
Public method UnsetActiveServer Unset the active server for the particular document.
Top
See Also