SingleServerService Class


Single Server Service Class

This class represents a single-server service inside Revit application. It is created when an instance of ISingleServerService is registered with Revit.
Inheritance Hierarchy
System Object
Autodesk.Revit.DB.ExternalService ExternalService
Autodesk.Revit.DB.ExternalService SingleServerService

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class SingleServerService : ExternalService

The SingleServerService type exposes the following members.

Properties
Name Description
Top
Methods
Name Description
Public method GetActiveServerId Returns the Id of the currently active application-level server of the service.
Public method GetActiveServerId(Document) Returns the Id of the server currently associated with the given document for the service.
Public method SetActiveServer(Guid) Set an active server applicable application-wide for the service.
Public method SetActiveServer(Guid, Document) Change the active server for a specific document.
Public method UnsetActiveServer Unset the active server for the particular document.
Top
See Also