HookAngle Property


The hook angle, measured in radians. Must be greater than 0 and no more than pi.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double HookAngle { get; set; }
Visual Basic
Public Property HookAngle As Double
	Get
	Set
Visual C++
public:
property double HookAngle {
	double get ();
	void set (double value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The given value for hookAngle is not a number
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: hookAngle must be greater than 0 and no more than pi.

See Also