HookAngle Property


Rebar Hook Type Hook Angle Property

The hook angle, measured in radians. Must be greater than 0 and no more than pi.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double HookAngle { get; set; }

Property Value

Double
Exceptions
Exception Condition
ArgumentException When setting this property: The given value for hookAngle is not a number
ArgumentOutOfRangeException When setting this property: hookAngle must be greater than 0 and no more than pi.
See Also