Gets the specified rule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- groupType
- Type: Autodesk.Revit.DBRoutingPreferenceRuleGroupType
The routing preference group type from which the rule should be returned.
- index
- Type: SystemInt32
The zero-based index where the rule should be returned.
Return Value
The rule at the specified group and zero-based index position.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | index is not a valid zero-based index within groupType. -or- Thrown if the index is out of bounds |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |