Routing |
Gets the specified rule.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public RoutingPreferenceRule GetRule(
RoutingPreferenceRuleGroupType groupType,
int index
)
Parameters
- groupType RoutingPreferenceRuleGroupType
- The routing preference group type from which the rule should be returned.
- index Int32
- The zero-based index where the rule should be returned.
Return Value
RoutingPreferenceRuleThe rule at the specified group and zero-based index position.

Exception | Condition |
---|---|
ArgumentException | index is not a valid zero-based index within groupType. -or- Thrown if the index is out of bounds |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |