SetFillPattern Method


Sets the FillPattern associated to this element.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public void SetFillPattern(
	FillPattern newFillPattern
)
Visual Basic
Public Sub SetFillPattern ( _
	newFillPattern As FillPattern _
)
Visual C++
public:
void SetFillPattern(
	FillPattern^ newFillPattern
)

Parameters

newFillPattern
Type: Autodesk.Revit.DBFillPattern
The new FillPattern object.

Remarks

The data stored inside the input FillPattern will be copied into this element. The input FillPattern itself will not be associated with the element.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException newFillPattern does not have a valid Target. -or- newFillPattern does not have a valid Name. -or- newFillPattern is a solid fill pattern. -or- newFillPattern contains FillGrids with a zero Offset. -or- The name of the newFillPattern already exists.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The element is the build-in solid fill pattern element and can not be modified.

See Also