Fill |
Sets the FillPattern associated to this element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- newFillPattern FillPattern
- The new FillPattern object.

Exception | Condition |
---|---|
ArgumentException | newFillPattern does not have a valid Target. -or- newFillPattern does not have a valid Name. -or- newFillPattern is a solid fill pattern. -or- newFillPattern contains FillGrids with a zero Offset. -or- The name of the newFillPattern already exists. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The element is the build-in solid fill pattern element and can not be modified. |

The data stored inside the input FillPattern will be copied into this element. The input FillPattern itself will not be associated with the element.