GetPlane Method


Gets the plane of the curve loop, if it is planar.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public Plane GetPlane()
Visual Basic
Public Function GetPlane As Plane
Visual C++
public:
Plane^ GetPlane()

Return Value

The plane of the curve loop.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException The curve loop does not lie in a single plane.

See Also