Constructs a new ViewOrientation3D using the input eye position, up and forward directions.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- eyePosition
- Type: Autodesk.Revit.DBXYZ
The eye position
- upDirection
- Type: Autodesk.Revit.DBXYZ
The up direction. This vector will be normalized. Up direction must be perpendicular to the forward direction.
- forwardDirection
- Type: Autodesk.Revit.DBXYZ
The forward direction. This vector will be normalized. Forward direction must be perpendicular to the up direction.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | One or both of the input vectors cannot be normalized. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | upDirection has zero length. -or- forwardDirection has zero length. |
Autodesk.Revit.ExceptionsArgumentsInconsistentException | The vectors upDirection and forwardDirection are not perpendicular. |